[HNUOJ 10014] The Triangle

The Triangle
Time Limit: 1000ms, Special Time Limit:2000ms, Memory Limit:32768KB
Total submit users: 2021, Accepted users: 1503
Problem 10014 : No special judgement
Problem description
7

3   8

8   1   0

2   7   4   4

4   5   2   6   5



(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

 
Input
Your program is to read from standard input. The first line contains one integer T, the number of test cases, for each test case: the first line contain a integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
 
Output
Your program is to write to standard output. The highest sum is written as an integer for each test case one line.
 
Sample Input
1

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
Sample Output
30
Problem Source
IOI 1994

AC:

#define _CRT_SECURE_NO_WARNINGS
#include<cstdio>
#include<cstring> 
#include<cstdlib>
#include <queue>

const int MAX_N = 105;

int dp[MAX_N][MAX_N];
int a[MAX_N][MAX_N];

int find(int i, int j, int n)
{
    if (i == n - 1) return dp[i][j] = a[i][j];
    return dp[i][j] != -1 ? dp[i][j] : dp[i][j] = a[i][j] + std::max(find(i+1, j + 1, n), find(i+1, j, n));
}

int main()
{
    int n, t;
    scanf("%d", &t);
    for (int times = 0; times < t; ++times)
    {
        memset(dp, -1, sizeof(dp));
        memset(a, 0, sizeof(a));
        scanf("%d", &n);
        for (int i = 0; i < n; ++i)
        {
            for (int j = 0; j < i + 1; ++j)
            {
                scanf("%d", &a[i][j]);
            }
        }
        printf("%d\n", find(0, 0, n));
    }
    
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值