02-线性结构3 Pop Sequence


02-线性结构3 Pop Sequence   (25分)

Given a stack which can keep MM numbers at most. Push NN numbers in the order of 1, 2, 3, ..., NN and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if MM is 5 and NN is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): MM (the maximum capacity of the stack), NN (the length of push sequence), and KK (the number of pop sequences to be checked). Then KK lines follow, each contains a pop sequence of NN numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO


#include<stdio.h>
#include<stdlib.h> 

#define MaxSize 1001 //堆栈最大深度 


struct SNode {
    int Data[MaxSize]; /* 存储元素的数组 */
    int Top;      /* 栈顶指针 */   // 
    int cap;       /* 堆栈最大容量 */
	//cap =Top+1; 
};
typedef struct SNode *Stack;
 
Stack CreateStack( );
void Pop( Stack S );
void Push( Stack S, int X );
int Cheak_stack(int v[],int M,int N);
int Top_data(Stack S);

int main()
{

	int M, N, K;

//M (the maximum capacity of the stack) 
//N (the length of push sequence) 
//K (the number of pop sequences to be checked)
	
	scanf("%d %d %d",&M,&N,&K);
	
	
	//存储push进的数据 
	int *value = (int*)malloc(sizeof(int)*N);//Value是数组; 
	
	//数据输入 
	for(int i = 0; i < K; i++){
		for( int j = 0; j != N; j++){
			scanf("%d",value+j);
		}
		if(Cheak_stack(value,M,N)){
			printf("YES\n");
		}
		else{
			printf("NO\n");
		}
	}
	return 0;
}

Stack CreateStack( )
{
    Stack S = (Stack)malloc(sizeof(struct SNode));
    S->Top = -1;
    S->cap = MaxSize;
    return S;
}	

void Push( Stack S, int X )
{
    if ( S->Top == S->cap-1 ) {
        printf("Full");
        return;
    }
    else {
        S->Data[++(S->Top)] = X;
        return ;
    }
}
 

int Top_data(Stack S)
{
	//给出Top所指向的元素
	return(S->Data[S->Top]); 
}


void Pop( Stack S )
{
    if ( S->Top == -1 ) {
        printf("Empty");
        return  ; 
    }
    //return ( S->Data[(S->Top)--] ); 
	S->Top--;        
}

int Cheak_stack(int v[],int M,int N)
{
	int new_cap = M;
	Stack s = CreateStack( );
	//在堆栈里做一个数用于比较进行压栈 
	Push(s,0);
	int index = 0;//index of v
	int num = 1;//Push进的数字,从1,2,3,4依次push。 
	
	while(index != N){
	//按顺序压入栈 1 2 3弹出数字后,接着从4,5,6压进栈 
		while(Top_data(s) < v[index] && index != N && (s->Top) < new_cap )
		//1.当要压入的数小于这个index所pop的数
		//2.pop的数的比对没有走完 
		//3.没有超过堆栈的最大深度 
		{
			Push(s,num++);
		}	 
		if(Top_data(s) == v[index]){
			Pop(s);
			index++;
		}
		else{
			return 0;
		}			
	}
	return 1;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值