BestCoder Round #52 (div.2) 1001 Victor and Machine

12 篇文章 0 订阅

Problem Description

Victor has a machine. When the machine starts up, it will pop out a ball immediately. After that, the machine will pop out a ball everywww seconds. However, the machine has some flaws, every time after xxx seconds of process the machine has to turn off for yyy seconds for maintenance work. At the second the machine will be shut down, it may pop out a ball. And while it's off, the machine will pop out no ball before the machine restart.

Now, at the 000 second, the machine opens for the first time. Victor wants to know when the nnn-th ball will be popped out. Could you tell him?

Input

The input contains several test cases, at most 100100100 cases.

Each line has four integers xxx,yyy,www and nnn. Their meanings are shown above。

1≤x,y,w,n≤1001\leq x,y,w,n\leq 1001x,y,w,n100.

Output

For each test case, you should output a line contains a number indicates the time when thennn-th ball will be popped out.

Sample Input
2 3 3 3
98 76 54 32
10 9 8 100
Sample Output
10
2664
939
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
    int x,y,w,n;
    while(cin>>x>>y>>w>>n)
    {
        int k = 1;
        int i;
        int sum = 0;
        for(i=1;;i++)
        {
            if(k == n)
            {
                printf("%d\n",i-1);
                break;
            }
            else
            {
                if(i%(x+y) == 0)
                {
                    k++;
                    sum = 0;
                }
                else if(i % (x+y) <= x)
                    sum++;
                if(sum == w)
                {
                    k++;
                    sum = 0;
                }
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值