uva 10327 Flip Sort

38 篇文章 0 订阅
9 篇文章 0 订阅

Sorting in computer science is an important part. Almost every problem can be solved effeciently if sorted data are found. There are some excellent sorting algorithm which has already acheived the lower bound n · lg n. In this problem we will also discuss about a new sorting approach. In this approach only one operation (Flip) is available and that is you can exchange two adjacent terms. If you think a while, you will see that it is always possible to sort a set of numbers in this way.
A set of integers will be given. Now using the above approach we want to sort the numbers in ascending order. You have to find out the minimum number of flips required. Such as to sort ‘1 2 3’ we need no flip operation whether to sort ‘2 3 1’ we need at least 2 flip operations.

Input
The input will start with a positive integer N (N ≤ 1000). In next few lines there will be N integers. Input will be terminated by EOF.

Output
For each data set print ‘Minimum exchange operations : M’ where M is the minimum flip opera- tions required to perform sorting. Use a seperate line for each case.

Sample Input
3
1 2 3
3
2 3 1

Sample Output
Minimum exchange operations : 0
Minimum exchange operations : 2

题意:
输出冒泡排序法交换次数(简化为求数组中逆序个数)

代码:

#include <iostream>
using namespace std;
int main()
{
    int n,num[10001],i,j,s;
    while(cin>>n)
    {
        getchar();
        s=0;
        for(i=0;i<n;i++)
        {
            cin>>num[i];
        }
        for(i=0;i<n;i++)
            {
                for(j=i+1;j<n;j++)
                {
                    if(num[j]<num[i])
                        s++;
                }
            }
        cout<<"Minimum exchange operations : "<<s<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值