二进制迷宫
Time Limit: 2000/1000ms (Java/Others)
Problem Description:
大白,上课的时候不小心进了一个八行八列二进制迷宫,数字0是路数字1是障碍,他希望你编写一个程序可以让他以最小步数走出迷宫,好让他可以快点重回现实世界,大白不仅可以上下左右走,更可以斜着走,斜着走或上下左右走都只算一步。坐标(0,0)为迷宫的入口,坐标(7,7)为出口
Input:
输入包括多组数据。
每组数据:输入n,表示有n个例子,输入八行八列的0,1的二进制迷宫。
Output:
如果大白能走出迷宫则输出最小步数,如果走不出迷宫则输出-1
Sample Input:
1
0 1 1 0 0 0 1 1
1 0 1 1 0 0 1 0
1 1 0 1 1 0 1 1
1 0 1 0 1 1 0 1
0 1 1 1 0 1 1 0
1 0 0 1 1 0 1 0
1 0 1 0 1 1 0 1
1 0 1 1 0 1 1 0
Sample Output:
7
#include <bits/stdc++.h>
using namespace std;
int n;
const int N = 8;
int mapp[N][N];
int vis[N][N];
int dd[][2] = {{-1, -1}, {-1, 0}, {-1, 1}, {0, -1}, {0, 1}, {1, -1}, {1, 0}, {1, 1}};
struct node{
int x, y, s;
node(){}
node(int a, int b, int c):x(a), y(b), s(c){}
};
bool check(int x, int y){
if(x < 0 || x > 7 || y < 0 || y > 7 || vis[x][y] || mapp[x][y])
return false;
return true;
}
int bfs(int x, int y){
queue <node> q;
memset(vis, 0, sizeof(vis));
node t = node(0, 0, 0);
q.push(t);
vis[0][0] = 1;
while(!q.empty()){
t = q.front();
q.pop();
if(t.x == 7 && t.y == 7)
return t.s;
for(int i = 0; i < 8; i++){
int xx = t.x + dd[i][0], yy = t.y + dd[i][1];
if(check(xx, yy)){
vis[xx][yy] = 1;
node tmp = node(xx, yy, t.s + 1);
q.push(tmp);
}
}
}
return -1;
}
int main(){
while(scanf("%d", &n) == 1){
while(n--){
for(int i = 0; i < 8; i++)
for(int j = 0; j < 8; j++)
scanf("%d", &mapp[i][j]);
int ans = bfs(0, 0);
printf("%d\n", ans);
}
}
return 0;
}
bfs加队列求迷宫最短路
最新推荐文章于 2023-02-22 01:06:10 发布