Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon’s home. But he can’t bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)….. A 3×4 bank grid is shown below:
Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers’ properties, so they live in the indestructible rooms and put customers’ properties in vulnerable rooms. Harry Potter’s precious are also put in some vulnerable rooms. Dudely wants to steal Harry’s things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can’t access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry’s precious are. He wants to collect all Harry’s precious by as less steps as possible. Moving from one room to another adjacent room is called a ‘step’. Dudely doesn’t want to get out of the bank before he collects all Harry’s things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry’s precious.
Input
There are several test cases.
In each test cases:
The first line are two integers N and M, meaning that the bank is a N × M grid(0 N,M <= 100).
Then a N×M matrix follows. Each element is a letter standing for a room. ‘#’ means a indestructible room, ‘.’ means a vulnerable room, and the only ‘@’ means the vulnerable room from which Dudely starts to move.
The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter’s precious in the bank.
In next K lines, each line describes the position of a Harry Potter’s precious by two integers X and Y, meaning that there is a precious in room (X,Y).
The input ends with N = 0 and M = 0
Output
For each test case, print the minimum number of steps Dudely must take. If Dudely can’t get all Harry’s things, print -1.
Sample Input
2 3
##@
#.#
1
2 2
#@##
....
####
....
1
2 4
0 0
Sample Output
-1
5
题意 :有1个起点和k个宝藏 如果不能拿到所有宝藏输出-1 不然会输出最小步数 我们可以通过广搜先求出起点到各个终点和 终点到其他终点的最小距离 再通过深搜来找出走过所有终点的最小的值
数据
2 3
##@
#.#
1
2 2
4 4
#@##
....
####
....
2
2 1
2 4
4 4
#@##
....
####
....
4
2 1
2 2
2 3
2 4
4 4
#@##
..#.
####
....
4
2 1
2 2
2 3
2 4
4 4
#@##
..#.
#.##
....
4
2 1
2 2
4 3
4 4
4 4
#@##
..#.
#.##
....
4
2 1
2 1
2 1
2 1
4 1
#
@
#
.
4
2 1
2 1
2 1
2 1
10 10
########@#
####.....#
###.####.#
#.#.####..
#.#.##.##.
#...#...#.
##.#..#.#.
##...#..#.
####.##.#.
####......
4
3 4
4 2
10 10
2 5
4 3
#@.
.##
.##
.##
3
1 2
1 2
1 3
3 3
#..
#..
@.#
2
3 1
1 3
2 4
.#.#
.@.#
4
1 1
1 3
2 1
2 3
#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
int mapp[200][200];
int v[200][200];
int x2,y2;
int n,m,k;
struct node
{
int x,y;
int time;
}e[10];
int ma;
int dp[10][10];//存终点到其他终点距离
int vis[10];
int go(int x,int y)
{
if(1<=x&&x<=n&&1<=y&&y<=m)
return 1;
return 0;
}
int dir[4][2]={{1,0},{-1,0},{0,-1},{0,1}};
int bfs(int x1,int y1,int x2,int y2)
{
queue<node>q;
node st,ed;
st.x=x1;
st.y=y1;
st.time=0;
memset(v,0,sizeof(v));
q.push(st);
v[x1][y1]=1;
while(!q.empty())
{
st=q.front();
q.pop();
if(st.x==x2&&st.y==y2)
return st.time;
for(int i=0;i<4;i++)
{
ed.x=st.x+dir[i][0];
ed.y=st.y+dir[i][1];
if(go(ed.x,ed.y)&&mapp[ed.x][ed.y]!='#'&&!v[ed.x][ed.y])
{
ed.time=st.time+1;
v[ed.x][ed.y]=1;
q.push(ed);
}
}
}
return -1;
}
void dfs(int e,int m,int kk)//e是当前位置,m是走到步数,kk是经过的终点数
{
if(kk==k)
{
ma=min(ma,m);
return;
}
for(int i=1;i<=k;i++)
{
if(!vis[i])
{
vis[i]=1;
dfs(i,m+dp[e][i],kk+1);
vis[i]=0;
}
}
return;
}
int main()
{
while(~scanf("%d%d",&n,&m)&&(n+m))
{
ma=inf;
int flag=1;
memset(v,0,sizeof(v));
for(int i=1;i<=n;i++)
{
getchar();
for(int j=1;j<=m;j++)
{
scanf("%c",&mapp[i][j]);
if(mapp[i][j]=='@')
{
x2=i;
y2=j;
}
}
}
scanf("%d",&k);
for(int i=1;i<=k;i++)
{
scanf("%d%d",&e[i].x,&e[i].y);
}
e[k+1].x=x2;//起点
e[k+1].y=y2;
for(int i=1;i<=k+1;i++)
for(int j=i+1;j<=k+1;j++)
{
int tt=bfs(e[i].x,e[i].y,e[j].x,e[j].y);
if(tt==-1)//出现-1说明不能走到所有终点
{
flag=0;
break;
}
dp[i][j]=dp[j][i]=tt;
}
if(flag==0)
{
printf("-1\n");
continue;
}
memset(vis,0,sizeof(vis));
vis[k+1]=1;
dfs(k+1,0,0);
printf("%d\n",ma);
}
}