hdu 3887 Counting Offspring(dfs序+树状数组)

Counting Offspring

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3284    Accepted Submission(s): 1118


Problem Description
You are given a tree, it’s root is p, and the node is numbered from 1 to n. Now define f(i) as the number of nodes whose number is less than i in all the succeeding nodes of node i. Now we need to calculate f(i) for any possible i.
 

Input
Multiple cases (no more than 10), for each case:
The first line contains two integers n (0<n<=10^5) and p, representing this tree has n nodes, its root is p.
Following n-1 lines, each line has two integers, representing an edge in this tree.
The input terminates with two zeros.
 

Output
For each test case, output n integer in one line representing f(1), f(2) … f(n), separated by a space.
 

Sample Input
  
  
15 7 7 10 7 1 7 9 7 3 7 4 10 14 14 2 14 13 9 11 9 6 6 5 6 8 3 15 3 12 0 0
 

Sample Output
  
  
0 0 0 0 0 1 6 0 3 1 0 0 0 2 0
 

Author
bnugong
 


#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
#include<queue>
#include<stack>
#define eps 1e-8
const int inf = 0x3f3f3f3f;
const long long mod=1e9+7;
const int N=100020;
using namespace std;
int n,p,cnt,k;
struct node
{
    int v,nxt;
}s[N*2];
int first[N];
int in[N],out[N];
int ans[N];
int ar[N];
int lowbit(int x)
{
    return x&-x;
}
void add(int i,int w)
{
    while(i<=n)
    {
        ar[i]+=w;
        i+=lowbit(i);
    }
}
int sum(int k)
{
    int ans=0;
    while(k)
    {
        ans+=ar[k];
        k-=lowbit(k);
    }
    return ans;
}
int dfs(int u,int pre)
{
        in[u]=++cnt;
    for(int i=first[u];i;i=s[i].nxt)
    {
        int v=s[i].v;
        if(v==pre)
            continue;
        dfs(v,u);
    }
    out[u]=cnt;
}
int main()
{
    int u,c;
    while(~scanf("%d%d",&n,&p)&&(n+p))
    {
        memset(first,0,sizeof(first));
        memset(ar,0,sizeof(ar));
        k=1,cnt=0;
        for(int i=1;i<n;i++)
        {
           scanf("%d%d",&u,&c);
        s[k].v = c;
        s[k].nxt = first[u];
        first[u] = k++;
        s[k].v=u;
        s[k].nxt=first[c];
        first[c]=k++;
        }
        dfs(p,-1);
       for(int i=1;i<=n;i++)
       {
           int rr=sum(out[i])-sum(in[i]-1);
           printf("%d%c",rr,((i==n)?'\n':' '));
           add(in[i],1);
       }
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值