UVA - 10943 How do you add?【组合数取余(递推)】

2 篇文章 0 订阅
1 篇文章 0 订阅

 Larry is very bad at math — he usually uses a calculator, whichworked well throughout college. Unforunately, he is now struck ina deserted island with his good buddy Ryan after a snowboardingaccident.They’re now trying to spend some time figuring out some goodproblems, and Ryan will eat Larry if he cannot answer, so his fateis up to you!It’s a very simple problem — given a number N, how many wayscan K numbers less than N add up to N?For example, for N = 20 and K = 2, there are 21 ways:0+201+192+183+174+165+15...18+219+120+0InputEach line will contain a pair of numbers N and K. N and K will both be an integer from 1 to 100,inclusive. The input will terminate on 2 0’s.OutputSince Larry is only interested in the last few digits of the answer, for each pair of numbers N and K,print a single number mod 1,000,000 on a single line.Sample Input20 220 20 0Sample Output2121
Input
Each line will contain a pair of numbers N and K. N and K will both be an integer from 1 to 100,
inclusive. The input will terminate on 2 0’s.
Output
Since Larry is only interested in the last few digits of the answer, for each pair of numbers N and K,

print a single number mod 1,000,000 on a single line.


Sample Input
20 2
20 2
0 0
Sample Output
21

21


求C(n,m)%10^6;

 

AC代码:

#include<cstdio>
#include<cstring>

typedef long long LL;
const LL MOD=1e6;

LL a[333][333];
 
int main()
{
	LL N,K; 
	memset(a,0,sizeof(a));
	for(int i=0;i<222;++i) a[i][0]=1;
	for(int i=1;i<222;++i) {
		for(int j=1;j<=i;++j) a[i][j]=(a[i-1][j]+a[i-1][j-1])%MOD; 
	} 
	while(~scanf("%lld%lld",&N,&K),N||K) {
		printf("%lld\n",a[N+K-1][K-1]); 
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值