1050 String Subtraction (20 分)

Given two strings S1​ and S2​, S=S1​−S2​ is defined to be the remaining string after taking all the characters in S2​ from S1​. Your task is simply to calculate S1​−S2​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1​ and S2​, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1​−S2​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

代码: 

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    int substract[128]={0};//用来存放“减数”中是否出现对应ASCII码值的字符
    char S1[10010],S2[10010];//用来存放“被减数”和“减数”字符串
    cin.getline(S1,10010);//因为字符串中可能出现空格,所以应该用cin.getline();
    cin.getline(S2,10010);
    int len1=strlen(S1),len2=strlen(S2);//len1,len2 分别存放被减数和减数字符串的长度
    for(int i=0;i<len2;i++)//遍历减数字符串,看都有哪些字符需要减去
        substract[S2[i]]=1;
    for(int i=0;i<len1;i++)//遍历被减数字符串,并判断该字符是否需要被减去
    {
        if(substract[S1[i]]==0)//若不需要被减去,则输出相应字符
            printf("%c",S1[i]);
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值