060 Are They Equal (25 分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

代码: 

#include<iostream>
#include<string>
using namespace std;
unsigned int N;
const string str=".";//小数点
int d1,d2;//用于记录幂次
string significant(string A,int &d)//返回significant digit以及对应幂次
{
    string s;
    int i=0,k=0,flag=1;//flag=1表示还未到小数点所在位置
    while(A[i]=='0'||A[i]=='.')//删除字符串前面多余的零
    {
        if(flag==0)
            k--;
        if(A[i]=='.')//经过小数点,那么之后每删除一个零,幂次减一
            flag=0;
        A.erase(i,1);//删除字符串前面多余的零
    }
    if(A.size()==0)//如果字符串中全为零或.,则幂次返回0
    {
        d=0;
        s="";
        return s;
    }
    i=A.size()-1;
    unsigned pos=A.find(str);//pos记录小数点的位置
    while(A[i]=='0')//删除字符串后面的0
    {
        A.erase(i--,1);
        if(pos>A.size())//如果小数点在最末尾,则幂次加一
            k++;
    }
    if(N<=pos)//如果要截取的长度短于整数部分长度
    {
            s=A.substr(0,(N<A.size()?N:A.size()));
            d=k+flag*(pos>A.size()?A.size():pos);
    }
    else
    {
        s=A.substr(0,pos)+A.substr(pos+1,N+1>A.size()?A.size()-pos-1:N-pos);
        d=pos;
    }
    return s;
}
void print(string A,int d)
{
    printf(" 0.%s",A.c_str());
    if(A.size()<N)
        for(int i=0;i<N-A.size();i++)
            printf("0");
    printf("*10^%d",d);
}
int main()
{
    string A,B;
    cin>>N>>A>>B;
    string strA=significant(A,d1);
    string strB=significant(B,d2);
    if(strA==strB&&d1==d2)
        printf("YES");
    else
    {
        printf("NO");
        print(strA,d1);
    }
    print(strB,d2);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值