1094 The Largest Generation (25 分)

这段代码实现了一个用广度优先搜索(BFS)解决家族树中查找最大人口数的世代问题。输入是家族成员数量和有孩子的家庭成员信息,输出是最大人口数及其所在的世代。程序首先读取输入,构建家族树,并通过BFS遍历找到最大人口的世代。
摘要由CSDN通过智能技术生成

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

 代码:

#include<iostream>
#include<queue>
#include<vector>
using namespace std;
struct node
{
    vector<int > child;
    int level;
}Node[110];
int N,M,MAX_level=1,k,maxp=0,nowp=0,nowl=-1;
void BFS(int root)
{
    queue<int > Q;
    Q.push(root);
    Node[root].level=1;
    while(!Q.empty())
    {
        int temp=Q.front();
        Q.pop();
        if(Node[temp].level==nowl)
            nowp++;
        else
        {
            if(nowp>maxp)
            {
                maxp=nowp;
                MAX_level=nowl;
            }
            nowl=Node[temp].level;
            nowp=1;
        }
        for(int i=0;i<Node[temp].child.size();i++)
        {
            Node[Node[temp].child[i]].level=Node[temp].level+1;
            Q.push(Node[temp].child[i]);
        }
    }
    if(nowp>maxp)
    {
        maxp=nowp;
        MAX_level=nowl;
    }
}
int main()
{
    int K,ID;
    scanf("%d%d",&N,&M);
    if(N==1&&M==0)
    {
        printf("1 1");
        return 0;
    }
    for(int i=1;i<=M;i++)
    {
        scanf("%d%d",&ID,&K);
        for(int j=0;j<K;j++)
        {
            int temp;
            scanf("%d",&temp);
            Node[ID].child.push_back(temp);
        }
    }
    BFS(1);
    printf("%d %d",maxp,MAX_level);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值