poj 2488 A Knight's Journey

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 29242 Accepted: 10028

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4


分析:

path数组结构:第一列存位置的行号,第二列存位置的列号。

A1  '1'
B2  '2 '
C3  '3'
D4  '4'
E5  '5'
F6  '6 



#include <stdio.h>
#include <string.h>
int mov[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};
int p,q,n,k,t;
int flag[30][30];
char path[30][2];

int dfs(int x,int y,int cur)       // 函数参量表示的意思:x表示行,y表示列,cur表示步数。
{ 
	int hx,hy,i;
    if(cur==p*q)   
    {
        t=1;
        return 1;
    }
    for(i=0;i<8;i++)
    {
        hx=x+mov[i][0];
        hy=y+mov[i][1];
        if(hx>=1 && hx<=q && hy>=1 && hy<=p && !flag[hx][hy])  // 
        {
            path[cur][0]=hx+'A'-1;    // 储存路径,即把 经过第cur步所达到位置 的行号、列号分别储存到path数组的第cur行的0,1列。
            path[cur][1]=hy+'0';      // 列号按字符处理     
            flag[hx][hy]=1;
            dfs(hx,hy,cur+1);
            if(t)   return 1;     //
            flag[hx][hy]=0;
        }
    }
    return 0;
}

int main()
{
    
    int i;
    scanf("%d",&n);
    for(k=1;k<=n;k++)
    {   
		t=0;
        scanf("%d%d",&p,&q);
        memset(flag,0,sizeof(flag));
        flag[1][1]=1;       //   设置标记
        path[0][0]='A';    // 将行(字母)、列(数字)序号放到path数组里面
        path[0][1]='1';

        printf("Scenario #%d:\n",k);
        if(dfs(1,1,1))
        {
            for(i=0;i<p*q;i++)
                printf("%c%c",path[i][0],path[i][1]);
        }
        else
            printf("impossible");
        printf("\n\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值