HDU 2709 Sumsets

30 篇文章 0 订阅
29 篇文章 0 订阅

Sumsets
Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3226    Accepted Submission(s): 1288


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
 

Input
A single line with a single integer, N.
 

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

Sample Input

7

 

Sample Output

6

 

Source
USACO 2005 January Silver
 

Recommend
teddy   |   We have carefully selected several similar problems for you:  2602 2716 2710 2717 2715

题意:问一个数划分成2的幂的和有几种分法》》》,由于方法数很大,对10^9取余;

思路:看了看别人的博客,递推得到:如果这个数是偶数,那么他等于他前面的那个数的方法数,否则等于他前面的那个数加上他的一半的那个数的方法数》》》

公式为:s[i]=s[i-1]; (偶数)

               s[i]=(s[i-1]+s[i/2])%mod;

之后打个表就可以了,复杂度O(1);

下面附上我的代码:

#include<cstdio>
const int N=1e6+10;
const int mod=1e9;
int s[N];
void solve()
{
	s[1]=1;
	for(int i=2;i<=N;i++)
	{
		if(i%2) s[i]=s[i-1];
		else
			s[i]=(s[i-1]+s[i/2])%mod;
	}
}
int main()
{
	int n;
	solve();
	while(~scanf("%d",&n))
	printf("%d\n",s[n]);
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值