String Matching(poj1580)

/*String Matching
Description


It's easy to tell if two words are identical - just check the letters. But how do you tell if two words are almost identical? And how close is "almost"? 


There are lots of techniques for approximate word matching. One is to determine the best substring match, which is the number of common letters when the words are compared letter-byletter. 


The key to this approach is that the words can overlap in any way. For example, consider the words CAPILLARY and MARSUPIAL. One way to compare them is to overlay them: 


CAPILLARY 
MARSUPIAL 


There is only one common letter (A). Better is the following overlay: 
CAPILLARY


     MARSUPIAL


with two common letters (A and R), but the best is: 
   CAPILLARY


MARSUPIAL


Which has three common letters (P, I and L). 


The approximation measure appx(word1, word2) for two words is given by: 
common letters * 2 
----------------------------- 
length(word1) + length(word2)


Thus, for this example, appx(CAPILLARY, MARSUPIAL) = 6 / (9 + 9) = 1/3. Obviously, for any word W appx(W, W) = 1, which is a nice property, while words with no common letters have an appx value of 0.
Input


The input for your program will be a series of words, two per line, until the end-of-file flag of -1. 
Using the above technique, you are to calculate appx() for the pair of words on the line and print the result. 
The words will all be uppercase.
Output


Print the value for appx() for each pair as a reduced fraction,Fractions reducing to zero or one should have no denominator.
Sample Input


CAR CART
TURKEY CHICKEN
MONEY POVERTY
ROUGH PESKY
A A
-1
Sample Output


appx(CAR,CART) = 6/7
appx(TURKEY,CHICKEN) = 4/13
appx(MONEY,POVERTY) = 1/3
appx(ROUGH,PESKY) = 0
appx(A,A) = 1
*/
#include<stdio.h>
#include<string.h>
int gcd(int m,int n)//求最大公约数; 
{
if(n==0)
return m;
else
return gcd(n,m%n);
}
int main()
{
char a[100],b[100];
while(scanf("%s",a)!=EOF)
{
if(strcmp(a,"-1")==0)
break;
else
scanf("%s",b);
int i,j,k,l,max=0,t;
int len1,len2,len;
len1=strlen(a);
len2=strlen(b);
for(i=0;i<len1;i++)/*相当于a[len1]不动,从,i=j=0开始,b[i++]与a[j++]比较,相同的话t++,
之后b[0]与a[i]比较,至到a[len-1]与b[i]比较记下t,并与之前的t比较,得出更大的t,后面继续从b[1]继续比较,直到最好能比较结束*/ 
{
k=0;
for(l=i,j=0;l<len1;l++,j++)
{
if(a[l]==b[j])
k++;
}
max=max>k?max:k;
}
for(i=0;i<len2;i++)//相当于b[len2]不动,与上面类似,比较容易举一反三。 
{
k=0;
for(l=i,j=0;l<len2;l++,j++)
{
if(b[l]==a[j])
k++;
}
max=max>k?max:k;
}
len=len1+len2,max*=2;
   t=gcd(max,len);
if(len==max)
{
   printf("appx(%s,%s) = 1\n",a,b);
   continue;//这个continue不能省略; 
   }
if(max==0)
{
   printf("appx(%s,%s) = 0\n",a,b);
       continue;
   }
else
printf("appx(%s,%s) = %d/%d\n",a,b,max/t,len/t);
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值