POJ 3111 K best 二分

这篇博客介绍了如何在珠宝收藏家Demy面临财务危机时,选择保留k个具有最大特定价值的珠宝。特定价值是珠宝价值与重量之比。这是一个01规划问题,可以通过牛顿迭代等方法解决。给出的输入包含珠宝的数量n和要保留的数量k,以及每件珠宝的价值vi和重量wi。输出应为Demy需要保留的珠宝编号,以实现最大特定价值。
摘要由CSDN通过智能技术生成

 

Demy has n jewels. Each of her jewels has some value vi and weight wi.

Since her husband John got broke after recent financial crises, Demy has decided to sell some jewels. She has decided that she would keep k best jewels for herself. She decided to keep such jewels that their specific value is as large as possible. That is, denote the specific value of some set of jewels S = {i1, i2, …, ik} as

.

Demy would like to select such k jewels that their specific value is maximal possible. Help her to do so.

Input

The first line of the input file contains n — the number of jewels Demy got, and k— the number of jewels she would like to keep (1 ≤ k ≤ n ≤ 100 000).

The following n lines contain two integer numbers each — vi and wi (0 ≤ vi ≤ 106, 1 ≤ wi ≤ 106, both the sum of all vi and the sum of all wi do not exceed 107).

Output

Output k numbers — the numbers of jewels Demy must keep. If there are several solutions, output any one.

Sample Input

3 2
1 1
1 2
1 3

Sample Output

1 2

 

正常的01分数规划

跟上一篇文章一样https://blog.csdn.net/heucodesong/article/details/80602317

乱搞一下 

输出即可

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
const int MAX_N = 1024;
int n,m;
double x;
struct node {
   int w;
   int s;
   bool operator < (const node& other) const{
      return w-x*s>other.w-x*other.s;
   }
}arr[MAX_N];
int check(double p){
    double total_a = 0, total_b = 0;
    x = p;
    sort(arr+1,arr+1+n);
    for(int i = 1;i<=(n-m);++i){
        total_a+=arr[i].w;
        total_b+=arr[i].s;
    }
    return total_a/total_b > p;
}
int main(){
 while(~scanf("%d%d",&n,&m)&&(n||m)){
    for(int i=1;i<=n;++i)
        scanf("%d",&arr[i].w);
    for(int i=1;i<=n;++i)
        scanf("%d",&arr[i].s);
    double l = 0,r=1;
    while(abs(r-l)>1e-4){
        double mid =(l+r)/2;
        if(check(mid)) l=mid;
        else r=mid;
    }
    printf("%.0f\n",l*100);
 }
 return 0;
}

耗时较久 可以用牛顿迭代

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值