poj 1338 ugly number

3 篇文章 0 订阅

Language:
Ugly Numbers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20855 Accepted: 9252

Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ... 
shows the first 10 ugly numbers. By convention, 1 is included. 
Given the integer n,write a program to find and print the n'th ugly number. 

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10

Source




#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
__int64 p[1505];
//p[1500]=859963392
int main()
{
	int n;
	int i,j;
	int b2,b3,b5;
	p[1]=1;
	b2=b3=b5=1;
    for(i=2;i<1550;i++)
    {
    	
    	__int64 temp=p[b2]*2;
    	if(temp>p[b3]*3)
    	   temp=p[b3]*3;
    	if(temp>p[b5]*5)
    	   temp=p[b5]*5;
    	p[i]=temp;   
    	if(p[i]==p[b2]*2)  b2++;
    	if(p[i]==p[b3]*3)  b3++;
    	if(p[i]==p[b5]*5)  b5++;
    	
    }
	while(scanf("%d",&n),n)
	{
		printf("%I64d\n",p[n]);
	}
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值