POJ 1426 Find The Multiple

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13039 Accepted: 5338 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

Dhaka 2002

解题思路:只能说这一题我没有想清楚吧,先摆这里,过了再说。主要思想是搜索,BFS和DFS都可以,先把1加入队列,每次取一个数据测试,不是的话就出列,再把队首元素乘以10和乘以10加1两个数依次入列,最后找到结果。另外100位数字是吓人的,在1到200的范围内结果用int64就可以了。

#include <iostream>
#include <queue>
using namespace std;
int n;
long long bfs()
{
     queue<long long> p;
     while(!p.empty())
     p.pop();
     p.push(1);
     while(1)
     {
             long long sum=p.front();
             if(sum%n==0)
             return sum;
             p.pop();
             p.push(10*sum);
             p.push(10*sum+1);
     }
}
int main()
{
    while(cin>>n&&n)
    {
         cout<<bfs()<<endl;
    }
    return 1;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值