PAT 甲级 1032 Sharing (25 分)

121 篇文章 0 订阅
115 篇文章 0 订阅

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

 

 

自己第一次写的方法 

    记得以前做过类似的链表题,动态链表的思路,是得知两个链表的长度,使长的链表先向前遍历长度差次,之后再一起遍历直到碰到一样的next。

测试点4 一直过不去。发现测试点4给出的两个首地址是相同的。

以下自己渣渣的写法,用到这道题上并不是很好。虽然能AC

#include <iostream>

using namespace std;

typedef struct Node {

	char data;
	int next;
};


int main() {


	int l1, l2, n;
	Node node[100010];
	cin >> l1 >> l2 >> n;

	for (int i = 0; i < n; i++)
	{
		int address, next;
		char data;
		cin >> address >> data >> next;
		node[address].data = data;
		node[address].next = next;
	}

	int size1 = 0, size2 = 0, offset;
	int p = l1, q = l2;
	while (node[p].next != -1)
	{
		p = node[p].next;
		size1++;
	}
	while (node[q].next != -1)
	{
		q = node[q].next;
		size2++;
	}

	size1++;
	size2++;

	offset = size1 > size2 ? size1 - size2 : size2 - size1;

	p = l1;
	q = l2;
	if (size1 > size2)
	{
		while (offset > 0)
		{
			p = node[p].next;
			offset--;
		}

	}
	else
	{
		while (offset > 0)
		{
			q = node[q].next;
			offset--;
		}
	}

	int res = -1;
	while (node[p].next != node[q].next)
	{
		p = node[p].next;
		q = node[q].next;
	}

	res = node[p].next;
    if(l1 == l2) res = l1;
	if (res == -1) printf("-1");
	else printf("%05d", res);

    return 0;
}

参考柳神的代码:

非常精炼,简单结构体中设置一个标志位(第一条链表中不存在的节点为false)

#include <iostream>
using namespace std;
struct {
    char key;
    int next;
    bool flag;
}node[100010];
int main(){
    int d1,d2,n;
    cin>>d1>>d2>>n;
    for(int i=0;i<n;i++){
        int t1,t2;
        char ch;
        cin>>t1>>ch>>t2;
        node[t1]={ch,t2,false};
    }
    for(int i=d1;i!=-1;i=node[i].next) node[i].flag=true;
    for(int i=d2;i!=-1;i=node[i].next) {
        if(node[i].flag){
            printf("%05d",i);
            return 0;
        }
    }
    printf("-1");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值