PAT 甲级 1065 A+B and C (64bit) 【大数溢出】

121 篇文章 0 订阅
115 篇文章 0 订阅

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题解:

题干有些小问题,测试数据中整数最大值为2^63-1 而不是2^63。

这样方便用溢出实现。正溢出范围: [-2^63,-2]

                                    负溢出范围: [0,2^63]

#include <cstdio>

int main(){

    int T,tcase = 1;
    scanf("%d",&T);
    while(T--){
        long long a,b,c;
        scanf("%lld%lld%lld",&a,&b,&c);
        long long res = a+b;
        bool flag;
        if(a>0 && b>0 && res<0) flag = true;
        else if(a<0 && b<0 && res>=0) flag = false;
        else if(res > c) flag = true;
        else flag = false;

        if(flag == true) printf("Case #%d: true\n",tcase++);
        else printf("Case #%d: false\n",tcase++);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值