1107 Social Clusters (30分) -- 并查集

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

作者: CHEN, Yue

单位: 浙江大学

时间限制: 1200 ms

内存限制: 64 MB

题解:

#include <iostream>
#include <algorithm>
using namespace std;

int course[1010] = { 0 };
int father[1010];
int countCluster[1010] = { 0 };

void init(int n) {
	for (int i = 1; i <= n; i++)
	{
		father[i] = i;
	}
}

int findFather(int x) {
	int a = x;
	while (x != father[x])
		x = father[x];
	//压缩路径
	while (a!=father[a])
	{
		int z = a;
		a = father[a];
		father[z] = x;
	}
	return x;
}

void Union(int a, int b) {
	int faA = findFather(a);
	int faB = findFather(b);
	if (faA != faB) {
		father[faA] = faB;
	}
}
bool cmp(int a, int b) {
	return a > b;
}

int main() {

	int n, k, h;
	cin >> n;
	init(n);
	for (int i = 1; i <= n; i++)
	{
		scanf("%d:", &k);
		for (int j = 0; j < k; j++)
		{
			cin >> h;
			if (course[h] == 0)
				course[h] = i;
			Union(i, findFather(course[h]));
		}
	}
	for (int i = 1; i <= n; i++)
	{
		countCluster[findFather(i)]++;
	}
	int ans = 0;
	for (int i = 1; i <= n; i++)
	{
		if (countCluster[i] != 0)
			ans++;
	}
	sort(countCluster + 1, countCluster + n + 1, cmp);
	cout << ans << '\n';
	for (int i = 1; i <= ans; i++)
	{
		cout << countCluster[i];
		if (i < ans) cout << ' ';
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值