HDU4726

Kia's Calculation

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3601    Accepted Submission(s): 763

 

 

Problem Description

Doctor Ghee is teaching Kia how to calculate the sum of two integers. But Kia is so careless and alway forget to carry a number when the sum of two digits exceeds 9. For example, when she calculates 4567+5789, she will get 9246, and for 1234+9876, she will get 0. Ghee is angry about this, and makes a hard problem for her to solve:
Now Kia has two integers A and B, she can shuffle the digits in each number as she like, but leading zeros are not allowed. That is to say, for A = 11024, she can rearrange the number as 10124, or 41102, or many other, but 02411 is not allowed.
After she shuffles A and B, she will add them together, in her own way. And what will be the maximum possible sum of A "+" B ?

 

 

Input

The rst line has a number T (T <= 25) , indicating the number of test cases.
For each test case there are two lines. First line has the number A, and the second line has the number B.
Both A and B will have same number of digits, which is no larger than 106, and without leading zeros.

 

 

Output

For test case X, output "Case #X: " first, then output the maximum possible sum without leading zeros.

 

 

Sample Input

 

1 5958 3036

 

 

Sample Output

 

Case #1: 8984

 

题意

给出两个位数一样的数,位数<=10^6;

数字的每一位都能移动, 但移动后的整数一定要是合法的, 即无前导零。 使得 A + B 最大

每一位的加法不向前进数,即 2 + 9 = 1; 不是11。

 

思路:

根据题意可知最后答案的位数和输入的位数一样;

如果是这种不会进数的加法,当然9是最大的,即从最大位到最小位是从9开始递减或不变的。

寻找可以构成什么样的数,肯定要先统计输入的两个数中,从1 ~ 9每个数有多少个;

这样才能方便找出能构成多大,多少个数;

如果对于某一个数x;

如果同时有 (a + b) > 10; (a + b) % 10 =x 和 a + b = x, 但是 a + b < 10;

肯定要先选后者(一直wa在此处)

因为前者的 a 和 b 要更大一些,可以用到更优的地方;

注意最大的位数是0的话,接下来的肯定全是0;

00000 就是 0;细节处要注意一下;

 

#include<bits/stdc++.h>
using namespace std;

#define EPS 1e-7
#define clr(x) memset(x, 0, sizeof(x))
#define long long ll
#define double db
#define PI acos(-1.0)

const int INF = 0x3f3f3f3f;
const int MOD=1000000007;
const int MAXN = 10000000;
const int dx[] = {1, -1, 0, 0};
const int dy[] = {0, 0, 1, -1};

char s1[MAXN], s2[MAXN];
int a[10],b[10];
int first()
{
    for(int i = 9; i >= 0; i--)
            for(int j = 1; j <= 9; j++)
            for(int k = 1; k <= 9; k++)
        {
            if(i == (j + k)%10)
            {
                if(a[j] > 0 && b[k] > 0)
                {
                    printf("%d", i);
                    a[j]--;
                    b[k]--;
                    return i;
                }

            }
        }
}
int main()
{
    int T;
    scanf("%d", &T);
    int cnt = 0;
    while(T--)
    {
        memset(a,0,sizeof a);
        memset(b,0,sizeof b);
        scanf("%s %s",s1,s2);
        int l=strlen(s1);
        for(int i=0; i<l; i++)
        {
            a[s1[i]-'0']++;
            b[s2[i]-'0']++;
        }
        printf("Case #%d: ", ++cnt);
        if(first())
        {
            for(int i = 9; i >= 0; i--)
                for(int j = 0; j <= 9; j++)
                for(int k = 0; k <= 9; k++)
            {
                if(i == (j + k)%10)
                {
                    while(a[j] > 0 && b[k] > 0)
                    {
                        printf("%d", i);
                        a[j]--;
                        b[k]--;
                    }

                }
            }
        }
        puts("");
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值