PAT (Advanced Level) 1146 Topological Order (25 分)

1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

Code:

#include <iostream>
#include <set>
#include <vector>
#include <cstring>
#pragma warning(disable:4996)

using namespace std;

const int maxn = 1005;
vector<int> g[maxn];
int in[maxn] = { 0 };
int n, m;

bool topoSort()
{
	int incopy[maxn];
	memcpy(incopy, in, sizeof(in));
	bool result = true;
	for (int i = 1; i <= n; i++)
	{
		int num; scanf("%d", &num);
		if (!result) continue;
		if (incopy[num] != 0) result = false;
		for (int j = 0; j<g[num].size(); j++)
			incopy[g[num][j]]--;
	}
	return result;
}

int main()
{
	scanf("%d%d", &n, &m);
	for (int i = 0; i<m; i++)
	{
		int v1, v2; scanf("%d%d", &v1, &v2);
		g[v1].push_back(v2);
		in[v2]++;
	}
	int q; scanf("%d", &q);
	vector<int> ans;
	for (int i = 0; i<q; i++)
	{
		bool b = topoSort();
		if (!b) ans.push_back(i);
	}
	for (int i = 0; i < ans.size(); i++) {
		if (i == 0) printf("%d", ans[i]);
		else printf(" %d", ans[i]);
	}
	return 0;
}

思路:

注意不要把上一组数据读到下一组!

bool topoSort()
{
	int incopy[maxn];
	memcpy(incopy, in, sizeof(in));
	for (int i = 1; i <= n; i++)
	{
		int num; scanf("%d", &num);
		if (incopy[num] != 0)
			return false;
		for (int j = 0; j<g[num].size(); j++)
			incopy[g[num][j]]--;
	}
	return true;
}

这样写是错的,因为假设q=3时的数据在topoSort时在i=3时直接return false,那么剩下的i=4、5…这些数据会在q=4时被读入导致WA

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值