PTA-自测-5 Shuffling Machine

题目来源:PTA-中国大学MOOC-陈越、何钦铭-数据结构-起步能力自测题

URL: https://pta.patest.cn/pta/test/17/exam/4/question/264/

原题内容:

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the ii-th position is jj, it means to move the card from position ii to position jj. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer KK (\le 2020) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 
22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 
D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题目解释:

这道题是一道简单的数组排序的题目,不过不是普通的排序,而是按照一定的规则去排序。原意是讲扑克牌的洗牌,现在要按照给定顺序洗给定的次数。并把54张洗好的牌顺序打印。


分析:

首先,我们可以将54张牌抽象成1-54的每个数字,然后再对这些数字进行排序,最后实例化为每一张牌,打印输出。


代码如下:

#include<iostream>
using namespace std;
int main() {
	int n;
	cin >> n;
	int card[60];
	int res[60];
	for (int i = 1; i <= 54; i++)
	{
		cin >> card[i];
		res[card[i]] = i;
	}
	for (int i = 1; i < n; i++)
	{
		int tmp[60];
		for (int j = 1; j <= 54; j++)
		{
			tmp[card[j]] = res[j];
		}
		for (int j = 1; j <= 54; j++)
		{
			res[j] = tmp[j];
		}
	}
	char a[5] = {'S','H','C','D','J'};
	for (int i = 1; i < 54; i++)
	{
		int t = res[i];
		cout << a[(t - 1) / 13] << (t - ((t - 1) / 13) * 13)<<" ";
	}
	int p = res[54];
	cout << a[(p - 1) / 13] << (p - ((p - 1) / 13) * 13) << endl;
	return 0; 
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值