PAT A1059. Prime Factors (25)

  1. Prime Factors (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HE, Qinming
Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi’s are prime factors of N in increasing order, and the exponent ki is the number of pi – hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

#include<cstdio>
#include<cmath>
using namespace std;
const int maxn=33;
int n;
int a[maxn];
int cnt=0;

void findp(int n){
    if(n<=1) return;
    for(int i=2;i<=n;i++){
        if(n%i==0){
            a[cnt++]=i;
            n/=i;
            findp(n);
            return;
        }
    }
}
int main(){
    scanf("%d",&n);
    printf("%d=",n);
    if(n==1){
        printf("1");
        return 0;
    }
    findp(n);
    printf("%d",a[0]);
    int k=1;
    for(int i=1;i<cnt;i++){
        if(a[i]==a[i-1]){
            k++;
        }else{
            if(k!=1)printf("^%d",k);
            k=1;
            printf("*%d",a[i]);
        }
    }
    if(k!=1)printf("^%d",k);
    return 0;
}

这里写图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值