PAT--1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991
#include <iostream>
#include <bits/stdc++.h>

using namespace std;

int main()
{
    int dig[200];
    long n,m;
    cin>>n>>m;
    int k = 0;
    int flag=0;
    long sum = n+m;
    if(sum<0)
        cout<<"-";
    int tempsum =abs(sum);


    do{
        dig[k++] = tempsum%10;
        tempsum = tempsum/10;
        flag++;
        if(flag%3==0)
        {
            dig[k++]=-1;
        }

    }while(tempsum);
    k = k-1;
    if(dig[k]==-1){
        k--;
    }

    for(; k>=0; k--)
    {
        if(dig[k]==-1)
            cout<<",";
        else
            cout<<dig[k];

    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值