HDU ACM 2138 How many prime numbers

原题描述

Problem Description

Give you a lot of positive integers, just to find out how many prime numbers there are.

Input

There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.

Output

For each case, print the number of prime numbers you have found out.

Sample Input

3
2 3 4

Sample Output

2

解题思路

本题求一组数中素数的个数。
求一个数是否是素数,把这个数一次除以2到他的平方根的整数,如果某个结果能整除,则不是素数。

参考代码

#include <iostream>
#include <cmath>
using namespace std;
bool isPrime(int x)                         // 调用函数比直接在main中判断更快
{
    if (x == 1)return false;
    for (int i = 2; i < sqrt(x); i++)       // 只要到sqrt(x)即可
        if (x%i == 0)
            return 0;
    return 1;
}
int main()
{
    int n, c, s;
    while (~scanf("%d",&n))
    {
        s = 0;
        for (int i = 0; i < n;i++)
        {
            scanf("%d", &c);
            if (isPrime(c))
                s++;
        }
        printf("%d\n", s);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值