题意是求满足给定长度的01串构成给定的数,一共有多少种方法,用动态规划,dp数组除了存储数位,大小,还需要考虑最后一位的情况,(1)如果最后一位是0,则在添加一位,串的长度变了,但值不变,即dp[i][j][0]=dp[i-1][j][0]+dp[i-1][j][1];
(2)如果最后一位是1,则dp[i][j]等于i-1长度值为j最后一位为0的情况和i-1长度下值为j-1且最后一位为1的情况的和,即
dp[i][j][1]=dp[i-1][j][0]+dp[i-1][j-1][1];
Description
For a string of n bits x1, x2, x3,…, xn, the adjacent bit count of the string (AdjBC(x)) is given by
x1 ∗ x2 + x2 ∗ x3 + x3 ∗ x4 + . . . + xn−1 ∗ xn
which counts the number of times a 1 bit is adjacent to another 1 bit. For example:
AdjBC(011101101) = 3
AdjBC(111101101) = 4
AdjBC(010101010) = 0
Write a program which takes as input integers n and k and returns the number of bit strings x of n bits (out of 2 n ) that satisfy AdjBC(x) = k. For example, for 5 bit strings, there are 6 ways of getting AdjBC(x) = 2:
11100, 01110, 00111, 10111, 11101, 11011
Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. Each data set is a single line that contains the data set number, followed by a space, followed by a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (k) giving the desired adjacent bit count. The number of bits (n) will not be greater than 100 and the parameters n and k will be chosen so that the result will fit in a signed 32-bit integer.
Output
For each data set there is one line of output. It contains the data set number followed by a single space, followed by the number of n-bit strings with adjacent bit count equal to k.
Sample Input
10
1 5 2
2 20 8
3 30 17
4 40 24
5 50 37
6 60 52
7 70 59
8 80 73
9 90 84
10 100 90
Sample Output
1 6
2 63426
3 1861225
4 168212501
5 44874764
6 160916
7 22937308
8 99167
9 15476
10 23076518
代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdlib>
using namespace std;
int dp[111][111][2];
int main()
{
int x,n,i,j,k,l,m,p;
scanf("%d",&n);
while(n--)
{
memset(dp,0,sizeof(dp));
dp[1][0][1]=1;
dp[1][0][0]=1;
l=0;
scanf("%d%d%d",&x,&m,&k);
for(i=2;i<=m;i++)
{
for(j=0;j<=k;j++)
for(p=0;p<2;p++)
{
if(p==0)
dp[i][j][p]=dp[i-1][j][0]+dp[i-1][j][1];
else
dp[i][j][p]=dp[i-1][j][0]+dp[i-1][j-1][1];
}
}
printf("%d %d\n",x,dp[m][k][0]+dp[m][k][1]);
}
return 0;
}