Wormholes(POJ-3259)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2..  M+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2..  MW+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back T seconds.
Output
Lines 1..  F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES

题目大意:有f个农场,每个农场有n个虫洞,m条双向通道,w条负权单向通道,问是否能回到从前?;

思路:题目即要我们判断是否有无负权环,用Bellman-ford算法;

代码如下:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
const int inf=0x3f3f3f3f;
int n,m,w,dist[510];
struct edge
{
    int s,e,d;
    edge(int a,int b,int l):s(a),e(b),d(l){};
};
vector<edge>v;
bool bellman_ford()
{
    memset(dist,inf,sizeof(dist));
    dist[1]=0;
    for(int i=1;i<n;i++)
    {
        bool flag=true;
        for(int j=0;j<v.size();j++)
            if(dist[v[j].s]+v[j].d<dist[v[j].e])
            {
                dist[v[j].e]=dist[v[j].s]+v[j].d;
                flag=false;
            }
        if(flag)
            return false;
    }
    for(int j=0;j<v.size();j++)
        if(dist[v[j].s]+v[j].d<dist[v[j].e])
            return true;
    return false;
}
int main()
{
    int f;
    cin>>f;
    while(f--)
    {
        int a,b,d;
        v.clear();
        cin>>n>>m>>w;
        for(int i=0;i<m;i++)
        {
            cin>>a>>b>>d;
            v.push_back(edge(a,b,d));
            v.push_back(edge(b,a,d));
        }
        for(int i=0;i<w;i++)
        {
            cin>>a>>b>>d;
            v.push_back(edge(a,b,-d));
        }
        if(bellman_ford())
            cout<<"YES\n";
        else
            cout<<"NO\n";
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值