1103. Integer Factorization (30)

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible

按题目要求分解成k个数的p次方的和,要求和最大。用dfs加剪枝来实现。第五个case比较耗时间,要尽量减少时间,比如不能用自带的pow函数,这个比较耗时间。


代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;

int n,k,p;
vector<int>res;
vector<int>mypow;
int max_idx;

void init_pow()
{
	for(int i=0;;i++)
	{
		int num=1;
		for(int j=0;j<p;j++)
		{
			num*=i;
		}
		mypow.push_back(num);
		max_idx=i;
		if(num>=400) return;
	}
}


int Max=0;
void dfs(int target,int count,int high,vector<int>fac)
{
	if(count==0)
	{
		if(target==0)
		{
			if(res.empty()) res=fac;
			else
			{
				int sum=0;
				for(int i=0;i<k;i++)
				{
					sum+=fac[i];
				}
				if(sum>Max) 
				{
					Max=sum;
					res=fac;
				}
			}
		}
		return;
	}
	if(target<count) return;
	while(mypow[high]>target-count+1) high--;
	for(int i=high;mypow[i]>=target/count;i--)
	{
		if(target>=mypow[i])
		{
			fac[count-1]=i;
			dfs(target-mypow[i],count-1,i,fac);
		}
	}
}

int main()
{
	cin>>n>>k>>p;
	init_pow();
	vector<int>fac(k);
	dfs(n,k,max_idx,fac);
	if(!res.empty())
	{
		reverse(res.begin(),res.end());
		printf("%d = %d^%d",n,res[0],p);
		for(int i=1;i<res.size();i++)
		{
			printf(" + %d^%d",res[i],p);
		}
	}
	else 
	{
		printf("Impossible");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值