POJ - 3126 Prime Path(bfs)

点击打开题目链接

 

Prime Path
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 20747Accepted: 11550

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source

[Submit]   [Go Back]   [Status]   [Discuss]

题目大意:将一个四位数的素数换成目标素数,每次只能换一个数字,每一步换完之后得到的仍是一个素数,并且得到的素数不能重复。求最小变换次数。

思路:首先求一遍素数。然后bfs不断枚举各位数字,满足要求的数字加入队列,直到得到结果。

附上AC代码:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>

using namespace std;
int prime[10000];
int vis[10000];
int st, en;
int T;

struct node {
	int num, step;
};
//筛法求素数
void is_prime(){
	int vis[10000];
	memset(vis, 0, sizeof(vis));
	for (int i = 2; i < 10000; i++)
	{
		if (!vis[i])
		{
			prime[i] = 1;
			for (int j = i*i; j < 10000; j += i)
				vis[j] = 1;
		}
	}
}

void bfs() {
	queue<node>q;
	q.push(node{ st, 0 });
	vis[st] = 1;
	while (!q.empty())
	{
		node temp = q.front();
		if (temp.num == en) {
			cout << temp.step << endl;
			return;
		}
		q.pop();
		int un = temp.num % 10;//个位
		int de = temp.num % 100 / 10;//十位
		//枚举个位
		for (int i = 1; i <= 9; i += 2)
		{
			int ans = temp.num - un + i;
			if (!vis[ans] && prime[ans] == 1)
			{
				vis[ans] = 1;
				q.push(node{ ans,temp.step + 1 });
			}
		}
		//枚举十位
		for (int i = 0; i <= 9; i++)
		{
			int ans = temp.num / 100 * 100 + i * 10 + un;
			if (!vis[ans] && prime[ans] == 1)
			{
				vis[ans] = 1;
				q.push(node{ ans,temp.step + 1 });
			}
		}
		//枚举百位
		for (int i = 0; i <= 9; i++)
		{
			int ans = temp.num / 1000 * 1000 + i * 100 + un + de * 10;
			if (!vis[ans] && prime[ans] == 1)
			{
				vis[ans] = 1;
				q.push(node{ ans,temp.step + 1 });
			}
		}
		//枚举千位
		for (int i = 1; i <= 9; i++)//千位不为0
		{
			int ans = temp.num % 1000 + i * 1000;
			if (!vis[ans] && prime[ans] == 1)
			{
				vis[ans] = 1;
				q.push(node{ ans,temp.step + 1 });
			}
		}
	}
	cout << "Impossible" << endl;
	return;
}

int main()
{
	is_prime();
	ios::sync_with_stdio(false);
	cin >> T;
	while (T--)
	{
		cin >> st >> en;
		memset(vis, 0, sizeof(vis));
		bfs();
	}
//	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Chook_lxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值