hdu 5879 Cure



Problem Description
Given an integer  n , we only want to know the sum of  1/k2  where  k  from  1  to  n .
 

Input
There are multiple cases.
For each test case, there is a single line, containing a single positive integer  n
The input file is at most 1M.
 

Output
The required sum, rounded to the fifth digits after the decimal point.
 

Sample Input
  
  
1 2 4 8 15
 

Sample Output
  
  
1.00000 1.25000 1.42361 1.52742 1.58044
依然是打表,但是他会出现负数,取绝对值就好。
然后还是错的。
然后发现1000000之前数都不会变了。
那大于1000000的输出之前就好。
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <stack>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;

#define LL long long
#define N 100005
#define mod 1000000007
double dp[1000000],sum=0,t;
int main()
{
    dp[0]=0;
    for(LL i=1;i<1000000;i++)
    {
        t=1.0/(i*i);
        sum+=t;
        dp[i]=sum;
    }
    LL n;
    while(~scanf("%lld",&n))
    {
        if(n<0) n=-n;
        if(n>=1000000) n=999999;
        printf("%.5lf\n",dp[n]);
    }
    return 0;
}


Problem Description
Given an integer  n , we only want to know the sum of  1/k2  where  k  from  1  to  n .
 

Input
There are multiple cases.
For each test case, there is a single line, containing a single positive integer  n
The input file is at most 1M.
 

Output
The required sum, rounded to the fifth digits after the decimal point.
 

Sample Input
   
   
1 2 4 8 15
 

Sample Output
   
   
1.00000 1.25000 1.42361 1.52742 1.58044
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值