HDU1542 Atlantis 离散化+线扫描

计算矩形面积的并。

首先对x坐标进行离散化,

然后在根据y坐标对线段排序,从下往上扫描,碰到下底则在相应区间内增加长度,如果遇到上底,则在相应区间内减去长度。要注意一个区间内可能覆盖的不止一条线段,所以上底-1 下地+1,如果一个区间内col为0时才代表这个区间内已经没有线段了。

Atlantis

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4807    Accepted Submission(s): 2140


Problem Description
There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
 

Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.
 

Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.
 

Sample Input
  
  
2 10 10 20 20 15 15 25 25.5 0
 

Sample Output
  
  
Test case #1 Total explored area: 180.00
 
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>

using namespace std;

#define MAXN 600
#define lson l,m,root<<1
#define rson m+1,r,root<<1|1

struct seg
{
    double l,r,h;
    int d;
}s[MAXN];

bool cmp(seg a,seg b)
{
    return a.h<b.h;
}

int n;
double hash[MAXN<<2];
double sum[MAXN<<2];
int col[MAXN<<2];

void push_up(int l,int r,int root)
{
    if(col[root])
        sum[root]=hash[r+1]-hash[l];
    else if(l==r)
        sum[root]=0;
    else
        sum[root]=sum[root<<1]+sum[root<<1|1];
}

void update(int l,int r,int root,int L,int R,int d)
{
    if(l>=L&&r<=R)
    {
        col[root]+=d;
        push_up(l,r,root);
        return;
    }
    int m=(l+r)>>1;
    if(L<=m) update(lson,L,R,d);
    if(R>m) update(rson,L,R,d);
    push_up(l,r,root);
}

int disp(int m)
{
	int mm=1;
	sort(hash+1,hash+1+m);
	for(int i=2;i<=m;i++)
		if(hash[i]!=hash[i-1])
			hash[++mm]=hash[i];
    return mm;
}

int gethash(int st,int ed,double k)
{
    int l=st,r=ed,m;
    while(l<=r)
    {
        m=l+(r-l+1)/2;
        if(hash[m]==k)
            return m;
        else if(hash[m]>k)
            r=m-1;
        else
            l=m+1;
    }
    return -1;
}

int main()
{
    int cs=1;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<n;i++)
        {
            double x1,y1,x2,y2;
            scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
            hash[1+i*2]=x1;
            hash[1+i*2+1]=x2;
            s[i*2].l=x1,s[i*2].r=x2,s[i*2].h=y1,s[i*2].d=1;
            s[i*2+1].l=x1,s[i*2+1].r=x2,s[i*2+1].h=y2,s[i*2+1].d=-1;
        }
        sort(s,s+n*2,cmp);
        int tot=disp(n*2);
        memset(col,0,sizeof(col));
        memset(sum,0,sizeof(sum));
        double ans=0;
        int l,r;
        for(int i=0;i<n*2-1;i++)
        {
            l=gethash(1,tot,s[i].l);
            r=gethash(1,tot,s[i].r)-1;
            update(1,tot,1,l,r,s[i].d);
            if(l<=r)ans+=(sum[1]*(s[i+1].h-s[i].h));
        }
        printf("Test case #%d\n",cs++);
        printf("Total explored area: %.2lf\n\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值