HDU 1728 逃离迷宫 (BFS)

逃离迷宫

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22263    Accepted Submission(s): 5421

Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?

Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2 ≤ m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1,x2对应列,y1, y2对应行。

Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。

Sample Input
  
  
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3

Sample Output
  
  
no yes

Source

Recommend
lcy   |   We have carefully selected several similar problems for you:  2102 1429 1983 1195 2717 

题解:给你一个图。图如题所述,再规定给你至多转弯的次数,起点和终点。问你在转弯的次数内能否到达终点。
       注意!给的n*m的map,n是列,m是行。。。 智障了。。。
       BFS。。。。

AC代码:
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
int k;int n,m;
char map[1110][1110];
char mark[1110][1110];
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
struct node
{
	int x,y;
	int times;
	int dir;
};
int bfs(node s,node e)
{
	s.times =0;
	s.dir=-1;
	queue<node>q;
	mark[s.y][s.x]=0;
	q.push(s);
	while(!q.empty())
	{
		node t=q.front();
		q.pop();
		if(t.x==e.x&&t.y==e.y&&t.times<=k)
		{
				return 1;		
		}	
        for(int i = 0 ; i < 4 ; ++i)
        {
            node temp;
            temp.x = t.x + dir[i][0];
            temp.y = t.y + dir[i][1];
            temp.dir = i;
            if(t.dir == -1)
            temp.times = 0;
            else if(temp.dir == t.dir)
            temp.times = t.times;
            else
            temp.times = t.times + 1;
            if(temp.x >= 1 && temp.y >= 1 && temp.x <= n && temp.y <= m && temp.times <=k && temp.times <= mark[temp.y][temp.x])
            {
                if(temp.x == e.x && temp.y == e.y)
                return 1;
                if(map[temp.y][temp.x]=='.')
                {
                    mark[temp.y][temp.x] = temp.times;
                    q.push(temp);
                }
            }
        }		
	}
	return 0;
}
int main()
{
	int t;

	int x1,x2,y1,y2;
	scanf("%d",&t);
	while(t--)
	{
			int flag=0;
		scanf("%d %d",&m,&n);
		for(int i=1;i<=m;i++)
		{
			getchar();  //注意,WA了2次 
			for(int j=1;j<=n;j++)
			{
				scanf("%c",&map[i][j]);
				mark[i][j]=110;
			}
		}
      //	getchar();
	    node s,e;
		scanf("%d %d %d %d %d",&k,&s.x,&s.y,&e.x,&e.y);
		
		if(bfs(s,e)) printf("yes\n");
		else printf("no\n");
	
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值