HDU 1570 A C(暴力)

A C

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5686 Accepted Submission(s): 3697

Problem Description
Are you excited when you see the title “AC” ? If the answer is YES , AC it ;

You must learn these two combination formulas in the school . If you have forgotten it , see the picture.

这里写图片描述

Now I will give you n and m , and your task is to calculate the answer .

Input
In the first line , there is a integer T indicates the number of test cases.
Then T cases follows in the T lines.
Each case contains a character ‘A’ or ‘C’, two integers represent n and m. (1<=n,m<=10)

Output
For each case , if the character is ‘A’ , calculate A(m,n),and if the character is ‘C’ , calculate C(m,n).
And print the answer in a single line.

Sample Input
2
A 10 10
C 4 2


Sample Output
3628800
6


Author
linle


Source
HDU 2007-1 Programming Contest
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    int n,m;
    char a;
    int as[11];
    as[0]=1;
    for(int i=1;i<=10;i++)
        as[i]=as[i-1]*i;
    while(t--)
    {
        getchar();
        scanf("%c %d %d",&a,&n,&m);
        if(a=='A')
        {
            printf("%d\n",as[n]/as[n-m]);
        }
        else
        {
            printf("%d\n",as[n]/(as[m]*as[n-m]));
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值