PAT (Advanced Level) Practice 1138 Postorder Traversal (25 分) 凌宸1642

PAT (Advanced Level) Practice 1138 Postorder Traversal (25 分) 凌宸1642

题目描述:

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

译:假设二叉树中的所有键都是不同的正整数。 给定前序和中序遍历序列,您应该输出相应二叉树的后序遍历序列的第一个数字。


Input Specification (输入说明):

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

译:每个输入文件包含一个测试用例。 对于每种情况,第一行给出一个正整数 N(≤ 50,000),即二叉树中节点的总数。 第二行给出前序序列,第三行给出中序序列。 一行中的所有数字都用空格分隔。


output Specification (输出说明):

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

译:对于每个测试用例,在一行中打印相应二叉树的后序遍历序列的第一个数字。


Sample Input (样例输入):

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output (样例输出):

3

The Idea:

  • 中序 + 先序 重建二叉树
  • 然后 DFS 进行后序遍历。

The Codes:

#include<bits/stdc++.h>
using namespace std ;
const int maxn = 50005 ;
struct node{
	int val ;
	node* lchild ;
	node* rchild ;
}; 

int pre[maxn] , in[maxn] , post[maxn] , n , ans , k = 0;

node* create(int preL , int preR , int inL , int inR){
	if(preL > preR) return NULL ;
	node* root = new node() ;
	root->val = pre[preL] ;
	int k = inL ;
	for( ; k <= inR ; k ++){
		if(in[k] == pre[preL])
			break ;
	}
	int numLeft = k - inL ;
	root->lchild = create(preL + 1 , preL + numLeft , inL , k - 1) ;
	root->rchild = create(preL + numLeft + 1 , preR , k + 1 , inR) ;
	return root ;
}

void postOrder(node* root){
	if(!root) return ;
	postOrder(root->lchild) ;
	postOrder(root->rchild) ;
	post[k++] = root->val ;
}
int main(){
	cin >> n ;
	for(int i = 0 ; i < n ; i ++) scanf("%d" , pre[i]) ; // 用 cin 的话, 最后一个测试点会超时 
	for(int i = 0 ; i < n ; i ++) scanf("%d" , in[i]) ;
	node* root = create(0 , n - 1 , 0 , n - 1) ;
	postOrder(root) ;
	cout << post[0] << endl ; 
	return 0 ;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lingchen0522

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值