一、题目
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than or equal to the node's key.
- The right subtree of a node contains only nodes with keys greater than the node's key.
- Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−10001000] which are supposed to be inserted into an initially empty binary search tree.
Output Specification:
For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:
n1 + n2 = n
where n1
is the number of nodes in the lowest level, n2
is that of the level above, and n
is the sum.
Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6
二、题目大意
输出一个二叉搜索树的最后两层结点个数a和b,以及他们的和c。
三、考点
二叉搜索树、DFS
四、注意
1、使用struct node{}建树;
2、DFS,保存最深深度,并保存所有的深度点的个数。
五、代码
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct node {
int val;
node *left, *right;
};
vector<int> vec_depth;
int max_depth = 0;
node* buildTree(node *root, int val) {
if (root == NULL) {
root = new node();
root->val = val;
root->left = root->right = NULL;
return root;
}
//left
if (val <= root->val)
root->left = buildTree(root->left, val);
//right
else
root->right = buildTree(root->right, val);
return root;
}
void dfs(node* root, int depth) {
if (root == NULL) {
max_depth = max(max_depth, depth);
return;
}
vec_depth[depth]++;
dfs(root->left, depth + 1);
dfs(root->right, depth + 1);
return;
}
int main() {
//read
int n;
cin >> n;
vec_depth.resize(n, 0);
//read and build tree
node *root = NULL;
for (int i = 0; i < n; ++i) {
int a;
cin >> a;
root = buildTree(root, a);
}
//dfs
dfs(root, 0);
//output
printf("%d + %d = %d", vec_depth[max_depth - 1], vec_depth[max_depth-2], vec_depth[max_depth-2] + vec_depth[max_depth - 1]);
system("pause");
return 0;
}