poj 3050 Hopscotch(dfs暴力)

27 篇文章 0 订阅
23 篇文章 0 订阅
Hopscotch
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3951 Accepted: 2627

Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS: 

111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

题意:给出一个5*5的矩阵,要求在矩阵中走6步,组成一个6位数字,问有多少种数字。

分析:用dfs对每一个点开始,然后搜索一遍,用vis标志这个数字有没有出现过,统计一下即可。

代码如下:

#include <stdio.h>
#include <string.h>
int map[20][20];
int vis[1000000];
int dir[4][2]={-1,0,1,0,0,-1,0,1};
int cnt=0;
void dfs(int x,int y,int val,int t)
{
	//printf("<%d %d %d %d>\n",x,y,val,t);
	if(t==5)
	{
		if(vis[val]==0)
		{
			vis[val]=1;
			cnt++;
		}
		return ;
	}
	for(int k=0;k<4;k++)
	{
		int px=x+dir[k][0];
		int py=y+dir[k][1];
		if(px>=0 && px<5 && py>=0 && py<5)
			dfs(px,py,val*10+map[px][py],t+1);	
	}
}

int main()
{
	int i,j;
	for(i=0;i<5;i++)
		for(j=0;j<5;j++)
			scanf("%d",map[i]+j);
	memset(vis,0,sizeof(vis));
	for(i=0;i<5;i++)
	{
		for(j=0;j<5;j++)
		{
			dfs(i,j,map[i][j],0);
		}
	}
	printf("%d\n",cnt);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值