1015 Reversible Primes (20 分)【进制转换,素数】

1015 Reversible Primes (20 分)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

 题目大意:

输入两个数,第一个是数字n第二是radix,如果数字n本身是素数且在radix进制下反转后仍然也是素数则输出Yes,否则输出No。

#include <iostream>
#include <cstdio>
#include <math.h>

using namespace std;

int isPrime(int num)
{
    if(num<=1)return false;
    int n = sqrt(num);
    for(int i = 2;i<=n;i++)
    {
        if(num%i==0)
            return false;
    }
    return true;
}

int Myreverse(int num,int radix)
{
    int len = 0;
    int n[100];
    while(num!=0)
    {
        n[len++] = num%radix;
        num = num/radix;
    }
    for(int i = 0;i<len;i++)
        num = num*radix+n[i];
    return num;
}

int main()
{
    int num,radix,rever;
    while(cin>>num)
    {
        if(num<0)break;
        cin>>radix;
        if(isPrime(num)==false)
        {
            printf("No\n");
            continue;
        }
        rever = Myreverse(num,radix);
        if(isPrime(rever))
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值