1046 Shortest Distance (20分)
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1 D2 ⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
解题思路:
首先,用一个数组dist2[i]保存i点到起点1的距离,这样当计算a,b两点间的距离则为tmp = |dist2[a]-dist2[b]|
此时,只要在比较一下tmp与总距离的一半sum/2之间的大小,若tmp小则输出tmp,否则输出sum-tmp。
#include<iostream>
#include<math.h>
using namespace std;
int dist1[100010], dist2[100010]; //dist1保存两点间的距离,dist2保存i到1点的距离
int main()
{
int n;
cin >> n;
int sum = 0;
for (int i = 1; i <= n; i++)
{
cin >> dist1[i];
sum += dist1[i];
dist2[i] = sum - dist1[i];
}
int q;
cin >> q;
while (q--)
{
int a, b;
cin >> a >> b;
int tmp = abs(dist2[a] - dist2[b]);
if (tmp < sum / 2)
cout << tmp << endl;
else
cout << sum - tmp << endl;
}
return 0;
}