poj3070

3 篇文章 0 订阅
0 篇文章 0 订阅
Fibonacci

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source


矩阵的快速幂运算。
m^n  % k 的快速幂:
递归
//计算a^bmodn     
int modexp_recursion(int a,int b,int n)     
{    
    int t = 1;

    if (b == 0)
        return 1;

    if (b == 1)
         return a%n;

    t = modexp_recursion(a, b>>1, n);

    t = t*t % n;

    if (b&0x1)
    {    
        t = t*a % n;
    }

    return t;
 } 
非递归
#include <iostream>   
using namespace std;   
  
//计算a^bmodn   
int modexp(int a,int b,int n)   
{   
    int ret=1;   
    int tmp=a;   
    while(b)   
    {   
       //基数存在   
       if(b&0x1) ret=ret*tmp%n;   
       tmp=tmp*tmp%n;   
       b>>=1;   
    }   
    return ret;   
}   
  
int main()   
{   
    cout<<modexp(2,10,3)<<endl;   
    return 0;   
}  
本题可以参考以上两种做法求解。
代码如下:
#include<stdio.h>

struct matrix {
    long a[2][2];
};

matrix multiply(matrix x, matrix y, long mod) {
    matrix tmp;
    tmp.a[0][0] = (x.a[0][0] * y.a[0][0] + x.a[0][1] * y.a[1][0]) % mod;
    tmp.a[0][1] = (x.a[0][0] * y.a[0][1] + x.a[0][1] * y.a[1][1]) % mod;
    tmp.a[1][0] = (x.a[1][0] * y.a[0][0] + x.a[1][1] * y.a[1][0]) % mod;
    tmp.a[1][1] = (x.a[1][0] * y.a[0][1] + x.a[1][1] * y.a[1][1]) % mod;
    return tmp;
}

matrix quick_pow(matrix x, long e, long mod) {
    matrix ret, tmp;
    if (!e) {
        ret.a[0][0] = 1;
        ret.a[0][1] = 0;
        ret.a[1][0] = 0;
        ret.a[1][1] = 1;
        return ret;
    }
    if (e == 1)
        return x;
    tmp = quick_pow(x, e >> 1, mod);
    ret = multiply(tmp, tmp, mod);
    if (e & 1)
        ret = multiply(ret, x, mod);
    return ret;
}

int main(void) {
    int n;
    matrix ans;
    while (scanf("%d", &n), n + 1) {
        ans.a[0][0] = 1;
        ans.a[0][1] = 1;
        ans.a[1][0] = 1;
        ans.a[1][1] = 0;
        if (n) {
            ans = quick_pow(ans, n - 1, 10000);
            printf("%ld\n", ans.a[0][0]);
        } else
            printf("0\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值