5-16 Sort with Swap(0, i)

5-16 Sort with Swap(0, i)   (25分)

Given any permutation of the numbers {0, 1, 2,..., N-1N1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the firstNN nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive NN (\le 10^5105) followed by a permutation sequence of {0, 1, ..., N-1N1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9


找环,然后根据表排序来。我也没用过表排序,跟着陈越姥姥说的来的。附图:

思路清楚了代码就很快了。

#include<iostream>
using namespace std;
int flag;
int main()
{
	long cnt=0,n,a[100005],t[100005];
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>a[i];
		t[a[i]]=i;
	}
	for(int i=0;i<n;i++)
	{
		if(a[i]!=i)
		{
			flag=0;
			while(a[i]!=i)
			{
				if(a[i]==0)
					flag=1;
				a[i]=i;
				i=t[i];
				cnt++;
			}
			if(flag==1)
				cnt--;
			else
				cnt++;
		}
	}
	cout<<cnt<<endl;
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

没想好叫什么名字

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值