[kmp]Number Sequence HDU1711

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

题意: 给定两个数字序列 a[] 和 b[]b[] 有可能整体作为一个连续子序列出现在了 a[] 中,现在请你找出 b[] 在 a[] 中第一次出现的位置(起始位置从 1 开始计数),如果一次都没有出现,请输出 -1。

分析: 一开始想分别把a[]和b[]所有数字连到两个string里,然后跑kmp,但是这样只针对每个数字都是个位的情况下是正确的。实际上把每个数字看作一个字符,直接跑kmp就可以了,于是这道题就轻而易举地解决了,但整数上跑kmp的思想还是很有意思的,例如结合字符串哈希,这道题还可以变成一道难度稍大的题目。

具体代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
//不过是把字符串上的kmp拿到int数组上而已 
int a[1000005], b[10005], _next[10005], n, m;

signed main()
{
	int T;
	cin >> T;
	for(int i = 1; i <= T; i++)
	{
		scanf("%d%d", &n, &m);
		for(int i = 1; i <= n; i++)
			scanf("%d", &a[i]);
		for(int i = 1; i <= m; i++)
			scanf("%d", &b[i]);
		for(int i = 2, j = 0; i <= m; i++)
		{
			while(j && b[j+1] != b[i])
				j = _next[j];
			if(b[j+1] == b[i])
				j++;
			_next[i] = j;
		}
		int ans = -1;
		for(int i = 1, j = 0; i <= n; i++)
		{
			while(j && b[j+1] != a[i])
				j = _next[j];
			if(b[j+1] == a[i])
				j++;
			if(j == m)
			{
				ans = i-j+1;
				break;
			}
		}
		printf("%d\n", ans);
	} 
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值