1121 Damn Single(30行代码+详细注释)

分数 25

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

代码长度限制

16 KB

时间限制

200 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
const int N=100010;
int n,m,couple[N],exist[N];
map<int,int>mp;
int main(){
    cin>>n;
    for(int i=0;i<n;i++){
        int a,b;
        cin>>a>>b;
        couple[a]=b,couple[b]=a;//夫妻 
        exist[a]=1,exist[b]=1;//已知存在的人 
    }
    cin>>m;
    int p[m];
    for(int i=0;i<m;i++){
        cin>>p[i];
        mp[p[i]]=1;//记录来派对的客人 
    }
    int res[m],cur=0;
    for(int i=0;i<m;i++)
        if(!mp[couple[p[i]]]||!exist[p[i]])res[cur++]=p[i];//若该客人没有伴侣或者不是已经记载的已知的存在的人,则记录在res中 
    sort(res,res+cur);//按编号从小到大排序 
    cout<<cur<<endl;//输出落单的人数 
    if(cur!=0){//不是0则输出这些人 
       printf("%05d",res[0]);
       for(int i=1;i<cur;i++)printf(" %05d",res[i]);    
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值