hdu4135 Co-prime

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 87    Accepted Submission(s): 39


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
  
  
2 1 10 2 3 15 5
 

Sample Output
  
  
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 

Source
 

Recommend
lcy


一看就是容斥原理的题,提取质因子然后容斥就可以了,初始化wa了一次,好久没做题了总犯些弱智错误……

代码:

#include <stdio.h>
#include <math.h>

int p[100];
int up;
long long ansa,ansb,ans;
long long a,b;

void DFS(int n,bool tag,long long num)
{
    if (n==up)
    {
        if (tag==1)
        {
            ansa-=a/num;
            ansb-=b/num;
        }
        else
        {
            ansa+=a/num;
            ansb+=b/num;
        }
        return;
    }
    DFS(n+1,tag,num);
    DFS(n+1,!tag,num*p[n]);
}

int main()
{
    int i,j,n,T,k,cnt;
    cnt=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%I64d%I64d%d",&a,&b,&n);
        a--;
        ansa=ansb=0;
        up=0;
        k=n;
        for (i=2;i<=sqrt(n*1.0);i++)
        {
            if (k%i==0)
            {
                while(k%i==0) k=k/i;
                p[up++]=i;
            }
        }
        if (k!=1)
        {
            p[up++]=k;
        }
        DFS(0,0,1);
      //  printf("%lld..%lld\n",ansb,ansa);
        printf("Case #%d: %I64d\n",cnt++,ansb-ansa);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值