1031. Hello World for U

Hello World for U

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h d
e  l
l   r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题意

给定一串字符串,按U形格式输出,使其尽可能接近正方形,要求最底下一行的长度不小于3。

思路

关键是要确定三边(实际只要左边和底边)长度。只要将字符串长度+2再三等分(取整)即为竖边长度,剩余的即为底边。


代码实现

#include <iostream>
#include <string>
using namespace std;

void printArray(string s)
{
    int n, a, b;

    n = s.length();
    a = (n + 2) / 3;        // 竖边长度
    b = n - 2 * a + 2;      // 底边长度

    for (int i = 0; i < a - 1; i++)     // 成对输出竖边
    {
        cout << s[i];
        for (int j = 0; j < b - 2; j++)
            cout << " ";
        cout << s[n - 1 - i] << endl;
    }

    for (int i = 0; i < b; i++)     // 输出底边
    {
        cout << s[a - 1];
        a++;
    }
}

int main()
{
    string s;

    cin >> s;
    printArray(s);

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值