hdu 1015 Safecracker【DFS】

Safecracker

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11640    Accepted Submission(s): 5997


Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST === 
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."
Sample Input
1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END
 


Sample Output
LKEBA
YOXUZ
GHOST
no solution
 


 

Source
 

题目大意:给你一个目标值,再给你一个主串,让你在主串中找到一个长度为5的子串【可跳跃选取】、以A对应1 Z对应26的法则,计算子串的值,子串第一个字母代表v,第二个字母代表w.....................找到使得函数v - w^2 + x^3 - y^4 + z^5 = target 成立的最大字典序子串。

思路:DFS

记录路径的部分一定要处理好。我记录的是子串内容,大家也可以修改成记录值。如果大家跟我一样记录子串内容的话,千万记得‘\0'的处理。

AC代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
#define intlong long int
char str[100];
char ans[100];
int vis[100];
int len;
int target;
void dfs(char output[],int cur)
{
    if(cur==5)
    {
        int v=output[0]-'A'+1;
        int w=output[1]-'A'+1;
        int x=output[2]-'A'+1;
        int y=output[3]-'A'+1;
        int z=output[4]-'A'+1;
        int sum=v-w*w+x*x*x-y*y*y*y+z*z*z*z*z;
        //if(strcmp(output,"YOXUZ")==0)printf("%d\n",sum);
        if(sum==target)
        {
            if(strcmp(output,ans)>0)
            {
                strcpy(ans,output);
            }
        }
        return ;
    }
    for(int i=0;i<len;i++)
    {
        if(vis[i]==0)
        {
            vis[i]=1;
            output[cur]=str[i];
            output[cur+1]='\0';
            dfs(output,cur+1);
            vis[i]=0;
        }
    }
}
int main()
{
    while(~scanf("%d%s",&target,&str))
    {
        if(target==0&&strcmp(str,"END")==0)break;
        len=strlen(str);
        memset(vis,0,sizeof(vis));
        char output[100];
        for(int i=0;i<=4;i++)
        {
            ans[i]=1;
        }
        ans[5]='\0';
        dfs(output,0);
        if(ans[0]==1)
        {
            printf("no solution\n");
        }
        else
        printf("%s\n",ans);
    }
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值