POJ2151-Check the difficulty of problems(概率DP)

Check the difficulty of problems
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 4512 Accepted: 1988

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972


题意:

有T支队伍参加比赛,比赛一共有M道题,要求算出第一名要至少做出N道题,且其他队伍都做出题目的概率


做法:

先算出每个队伍至少做出一题的概率,然后减去所有队解题数都小于N题且大于1题的概率,即为所求。

很简单的概率DP,DP[i][j]表示一支队伍解前i道题,解出j题的概率,递推即可


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int M,T,N;
double p[1010][40];
double dp[40][40];
int main(){

    while(~scanf("%d%d%d",&M,&T,&N) && N+T+M){
        double all  = 1.0;
        for(int i = 0; i < T; i++){
            double t = 1.0;
            for(int j = 0; j < M; j++){
                scanf("%lf",&p[i][j]);
                t *= (1-p[i][j]);
            }
            all *= (1-t);
        }
        double no = 1.0;
        for(int i = 0; i < T; i++){
            dp[0][0] = 1-p[i][0];
            dp[0][1] = p[i][0];
            for(int j = 1; j < M; j++){
                dp[j][0] = dp[j-1][0]*(1-p[i][j]);
                for(int k = 1; k <= j+1; k++){
                    dp[j][k] = dp[j-1][k]*(1-p[i][j])+dp[j-1][k-1]*p[i][j];
                }
            }
            double t = 0.0;
            for(int j = 1; j < N; j++){
                t += dp[M-1][j];
            }
            no *= t;
        }
        printf("%.3f\n",all-no);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值