1027 Colors in Mars (20分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

 题目大意:

火星人使用相同的方式在电脑上表示颜色。色彩由6位数字来表示,前两位表示红色,中间两位表示绿色,最后两位表示蓝色,与地球人的表示方式不同之处在于他们使用13进制而不是16进制来表示颜色。现给出三个十进制的数字,要求你输出火星人的RGB值。

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm> 
using namespace std;
void change(int color){
	string s;
	while(color){
		int a = color % 13;
		color = color / 13;
		char aa;
		if(a > 9)
			aa = 'A'+(a-10);
		else
			aa = a + '0';
		s += aa;
	}
	reverse(s.begin(),s.end());
	for(int i = 1 ; i <= 2-s.length() ; i ++)
		printf("0");
	cout<<s;
}
int main(){
	int color[3];
	scanf("%d%d%d",&color[0],&color[1],&color[2]);
	printf("#");
	for(int i = 0 ; i < 3 ; i ++)
		change(color[i]);
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值