android模拟器运行opengles2.0程序

在网上找了资料,都是说了一大篇,实际只需做如下操作:

1、新建模拟器,选择4.0.3以上版本;

2、在模拟器的“emulation options"选中"use host GPU",这样才可以在模拟器中运行OpenGL ES 2.0的程序;

3、代码段中,在setRenderer前需调用setEGLConfigChooser:setEGLConfigChooser(8, 8, 8, 8, 16, 0);否则会报异常:java.lang.IllegalArgumentException: No config chosen


模拟器设置和代码做以上配合,就可正常运行opengles2.0

展开阅读全文

没有更多推荐了,返回首页