G - stl 的 优先队列

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1n2 and n (1 ≤ n1n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input
1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0
Sample Output
3.500000
562.500000
Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.


STL的优先队列,创建模拟最大堆和最小堆,并维护长度范围

代码如下:

//
//  main.cpp
//  G - stl 的 优先队列
//
//  Created by 徐智豪 on 2017/3/30.
//  Copyright © 2017年 徐智豪. All rights reserved.
//
#include <iostream>
#include <queue>
#include <iomanip>
using namespace std;
int main(int argc, const char * argv[]) {
    long long n,n1,n2;
    cin>>n1>>n2>>n ;
    {
        if(!n&&!n1&&!n2)
            return 0;
        long long num=0,sum=0;
        priority_queue<long long> small,big;
    for(int i=0;i<n;i++)
    {
        cin>>num;
        sum+=num;
        big.push(-num);
        if(big.size()>n1)
            big.pop();
        small.push(num);
        if(small.size()>n2)
            small.pop();
    }
        for(int i=0;i<n1;i++)
    {
        sum+=big.top();
        big.pop();
    }
        for(int i=0;i<n2;i++)
    {
        sum-=small.top();
        small.pop();
    }
    cout<<setprecision(6)<<fixed<<(sum*1.0/(n-n1-n2))<<endl;
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值